USERS CURRENTLY ONLINE ON DISCORD

Become one of us today, click to join!

Using the clientside mods OptiFine and VoxelMap on 1.13.2 servers

TawnyFrogmouth

Well-Known Member
Emperor
Two of the four regular servers now run server version 1.13.2, and playing on them requires a matching client version. Since Forge and LiteLoader haven't yet updated to 1.13, most client mods aren't usable yet on those servers.

Two key mods, however, can already be used with 1.13.2 clients: OptiFine and VoxelMap. This is a short guide to installing these mods.

VoxelMap
Previous versions of VoxelMap required the mod system LiteLoader, but the current beta build for 1.13.2 instead uses Rift, a new, lightweight modding API/library/modloader. The latest official build supports 1.13 but not 1.13.2, but a fork of the project created by Chocohead does support 1.13.2. To install VoxelMap with Rift:
  1. Open the Minecraft Launcher and run a 1.13.2 version of the client.
  2. Close Minecraft.
  3. Download and install Chocohead's Rift fork for 1.13.2.
  4. Download the newest build of VoxelMap for 1.13.2 and save the .jar file in your minecraft/mods folder.
  5. Reopen the Minecraft launcher, and run the new version created in step 3, named {X}-rift-1.0.4-SNAPSHOT, where {X} is the name of the version run in step 1.
OptiFine
If you have already installed Chocohead's Rift fork for 1.13.2 using steps 1-3 of the previous instructions:
  1. Download OptiFine 1.13.2 HD U E4 and save the .jar file in your minecraft/mods folder.
Alternatively, as with previous versions of the mod, OptiFine can be installed without a modloader as follows:
  1. Open the Minecraft Launcher and run a 1.13.2 version of the client.
  2. Close Minecraft.
  3. Download and then install OptiFine 1.13.2 HD U E4
  4. Reopen your Minecraft Launcher, and run the new version created by the previous step, named {X}-OptiFine_HD_U_E4, where {X} is the name of the version run in step 1.
 

aredninja16

Free Spwite Cwanbwrry for everyone!
Emperor
I had some sort of crash issue, I forget what the message was, what I did was rename the mods folder to mods1 and made a new folder named mods, then moved over the two mod files. It launched after that for me
 

MadMikael

Well-Known Member
Emperor
I want to give a big thanks to Tawny for making this guide, as I did enjoy using the minimap for a while.

However, I'm sad to say that something updated yesterday, and currently Rift is not compatible with Optifine.
There are multiple bug reports now on it... the game will crash on launch.
So until the issue is addressed, I'm sad to say that any looking to use the minimap in this way will need to go without optifine.
 

aredninja16

Free Spwite Cwanbwrry for everyone!
Emperor
I have come to realize since my last reply that having both 1.12.2 optifine and 1.13.2 optifine in the same folder when launching 1.13 will crash the game at launch. Hopefully this helps someone else
 

MadMikael

Well-Known Member
Emperor
I can't get rift. It gives me this error message. "
Tag or commit 'jitpack-d4cd7b00a-1' not found. Rechecking."
Alright, I've looked into this.
It seems the download link is broken, and I can't seem to find another working one on the official site.
It is reported as broken on the report page.

Perhaps Tawny will have better luck.

In the meantime, I've uploaded a copy of the file I downloaded in February to google drive, and I'm willing to share it with anyone who requests it (I'm unsure if it's a good idea to post it publicly).
You can reply here, or contact me here or on discord MadMikael#6914
and I'll give you the link.
It is a jar file, and as such it may give off warnings etc., but it's the same file I downloaded from the link above when it worked.

EDIT: I've also come across this issue here https://github.com/DimensionalDevelopment/Rift/issues/85
And I believe changing a single line in the json will fix it.
 
Last edited: